Quantcast

yap | problems rendering some .eps files

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

yap | problems rendering some .eps files

Evan Cooch
I run into this only occasionally, but when I do, it's somewhat of a
pain -- for some of the .eps graphics files I use, yap absolutely won't
render the .dvi file that contains them, regardless of the settings (in
yap, or when I generate the .eps file). You can grab a MWE (.tex file
and .eps file) showing an example of this, here: https://tinyurl.com/zw6pqj9

What is strange is that if I use .tex -> .dvi -> .pdf, image renders
perfectly. If I print the image to a PS printer, prints perfectly. If I
use GS to convert directly from .eps -> .pdf, works perfectly. And,
every other .dvi viewer I try has no problem -- the .dvi file renders
perfectly. The only situation where there is a problem is...yap
absolutely refuses to render it.

Specifics:

Image is PostScript 3 (changing to PS 2 makes no difference), fonts as
curves (although embedding as native fonts makes no difference). Even
tried running eps2eps, but that made no difference.  Yap (latest and
greatest version -- 64-bit) is set to use dvips as the default rendering
method. if I try a compile, I get the following error message from yap:
first, error popup that the page could not be rendered. here is the log:

MiKTeX Problem Report
Message: The page could not be rendered.
Data:
Source: Libraries\MiKTeX\Dvi\DviPage.cpp
Line: 752
MiKTeX: 2.9
OS: Windows 7 Professional, 64-bit, Service Pack 1, build 7601
Invokers: explorer/WinEdt
SystemAdmin: no
PowerUser: no
Root0: C:\Users\egc\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\egc\AppData\Local\MiKTeX\2.9
Root2: C:\Users\egc\Desktop\egc\text\MikTeX
Root3: C:\ProgramData\MiKTeX\2.9
Root4: C:\Program Files\MiKTeX 2.9
UserInstall: C:\Users\egc\Desktop\egc\text\MikTeX
UserConfig: C:\Users\egc\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\egc\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9


While this isn't a huge deal (I can go from .tex -> .dvi -> .pdf without
problems), it is a nuisance, since my workflow is .tex <-> .dvi (do
forever), and I only generate the PDF at the end. What I'm after here
are suggestions as to what I might try? I'm puzzled as to what yap is
choking on, whereas other .dvi viewers don't seem to have any problems
at all with this particular image? This isn't a criticism of yap (which
I use very successfully, except in this occasional case) -- but perhaps
its a latent bug?

Thanks in advance...



------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.http://sdm.link/xeonphi
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml
Loading...