Quantcast

latexmk error (Win10)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

latexmk error (Win10)

Marciano Siniscalchi
I installed latexmk using the package manager. However, upon running it
(e.g., with latexmk -v, or anything else), I get the following error
message:

Can't locate Digest/MD5.pm in @INC (you may need to install the Digest::MD5
module) (@INC contains: C:/Program Files (x86)/LyX 2.2/Perl/lib .) at
C:\Program Files (x86)\MiKTeX 2.9\scripts\latexmk\perl\latexmk.pl line 134.
BEGIN failed--compilation aborted at C:\Program Files (x86)\MiKTeX
2.9\scripts\latexmk\perl\latexmk.pl line 134.

--
Marciano Siniscalchi
Economics Department, Northwestern University
http://faculty.wcas.northwestern.edu/~msi661
------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: latexmk error (Win10)

George N. White III
On Mon, Sep 19, 2016 at 7:44 PM, Marciano Siniscalchi <
[hidden email]> wrote:

> I installed latexmk using the package manager. However, upon running it
> (e.g., with latexmk -v, or anything else), I get the following error
> message:
>
> Can't locate Digest/MD5.pm in @INC (you may need to install the Digest::MD5
> module) (@INC contains: C:/Program Files (x86)/LyX 2.2/Perl/lib .) at
> C:\Program Files (x86)\MiKTeX 2.9\scripts\latexmk\perl\latexmk.pl line
> 134.
> BEGIN failed--compilation aborted at C:\Program Files (x86)\MiKTeX
> 2.9\scripts\latexmk\perl\latexmk.pl line 134.


MikTeX and LyX (as well as TeX Live) all provide stripped-down perl systems
tailored
to their needs. None of these provides a complete perl system, so if you
want to
use perl scripts from optional MiKTeX packages you need to install a full
perl system.

See:
http://bquistorff.blogspot.ca/2015/01/getting-latexmk-working-within-lyx.html

--
George N. White III <[hidden email]>
Head of St. Margarets Bay, Nova Scotia
------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: latexmk error (Win10)

Marciano Siniscalchi
>
> MikTeX and LyX (as well as TeX Live) all provide stripped-down perl systems
> tailored
> to their needs. None of these provides a complete perl system, so if you
> want to
> use perl scripts from optional MiKTeX packages you need to install a full
> perl system.
>
> See:
> http://bquistorff.blogspot.ca/2015/01/getting-latexmk-
> working-within-lyx.html
>
> --
> George N. White III <[hidden email]>
> Head of St. Margarets Bay, Nova Scotia
> ------------------------------------------------------------
> ------------------
>

​Thanks George! That did it. (Now, it would be great if MikTeX integrated
the appropriate version of Perl, or at least alerted the user to the need
for it, but no matter.)​
------------------------------------------------------------------------------
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml
Loading...