Quantcast

Yap 2.9.3987 won't open dvi

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Yap 2.9.3987 won't open dvi

murrayE
Here's a minimal example showing the same Yap error I reported several
days ago, but now running latex and yap from command line.

Command-line steps:

   latex testyap.tex
   yap testyap.dvi


In Yap, initially I get MiKTeX Problem Report window saying, "Not all
fonts could be loaded...."  Then yap says it's an invalid .dvi (yet I
can convert it dvi -> ps and ps -> pdf just fine!).

If I try to dismiss the MiKTeX Problem Report window, eventually Yap
locks up and I have to use Windows Task Manager to end it.

Platform:  Windows XP Pro (SP3)

   === LaTeX source file ===
\documentclass{article}
\begin{document}
This is a test document by Murray.
\end{document}

   === MiKTeX Problem Report generated automatically by Yap ---

MiKTeX Problem Report
Message: Invalid DVI file.
Data:
Source: C:\work3\miktex-2.9\Libraries\MiKTeX\Dvi\Dvi.cpp
Line: 1108
MiKTeX: 2.9
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
Invokers: explorer/cmd
SystemAdmin: yes
PowerUser: no
Root0: C:\Documents and Settings\Administrator\Application Data\MiKTeX\2.9
Root1: C:\Documents and Settings\Administrator\Local
Settings\Application Data\MiKTeX\2.9
Root2: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.9
Root3: D:\WP\localtexmf
Root4: D:\WP\MiKTeX 2.9
UserInstall: C:\Documents and Settings\Administrator\Application
Data\MiKTeX\2.9
UserConfig: C:\Documents and Settings\Administrator\Application
Data\MiKTeX\2.9
UserData: C:\Documents and Settings\Administrator\Local
Settings\Application Data\MiKTeX\2.9
CommonInstall: D:\WP\MiKTeX 2.9
CommonConfig: C:\Documents and Settings\All Users\Application
Data\MiKTeX\2.9
CommonData: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.9

(What in the world is C:\work3\miktex-2.9\Libraries\ ?? Why is THAT there?)

   ==== DebugView log file ===
[4572] 62 [yap.yap]: Yap arguments: testyap.dvi
[4572] 1390 [yap.core]: Access is denied.
[4572]
[4572] Function: CreateProcess
[4572] Result: 5
[4572] Data: D:\WP\MiKTeX 2.9\miktex\bin\miktex-makepk.exe
[4572] Source: Libraries\MiKTeX\Core\win\winProcess.cpp:359
[3012] <<UI>>
[3012] MMTask compacting.
[3012]
[3012] <<UI>>
[3012] MMTask compacted, 1687552 bytes in largest available block.

   === Start of Windows XP PATH setting ===
D:\WP\MiKTeX 2.9\miktex\bin;C:\WINDOWS\system32;C:\WINDOWS

(although I have MiKTeX 2.8 also installed -- and with Yap working with
same .tex source -- it's not on the PATH)


--
Murray Eisenberg                     [hidden email]
Mathematics & Statistics Dept.
Lederle Graduate Research Tower      phone 413 549-1020 (H)
University of Massachusetts                413 545-2859 (W)
710 North Pleasant Street            fax   413 545-1801
Amherst, MA 01003-9305

------------------------------------------------------------------------------
Lotusphere 2011
Register now for Lotusphere 2011 and learn how
to connect the dots, take your collaborative environment
to the next level, and enter the era of Social Business.
http://p.sf.net/sfu/lotusphere-d2d
_______________________________________________
MiKTeX-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/miktex-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Yap 2.9.3987 won't open dvi

murrayE
Addendum:

If I double-click the .dvi in Windows Explorer to open it in Yap, then I
can dismiss the MiKTeX Problem Report window and examine the Document
Properties. The Document Properties dialog says cmr10 is not loadable.
But it won't give me any details when I double-click the place it says
to double-click for details.

On 12/17/2010 11:20 PM, Murray Eisenberg wrote:

> Here's a minimal example showing the same Yap error I reported several
> days ago, but now running latex and yap from command line.
>
> Command-line steps:
>
> latex testyap.tex
> yap testyap.dvi
>
>
> In Yap, initially I get MiKTeX Problem Report window saying, "Not all
> fonts could be loaded...." Then yap says it's an invalid .dvi (yet I can
> convert it dvi -> ps and ps -> pdf just fine!).
>
> If I try to dismiss the MiKTeX Problem Report window, eventually Yap
> locks up and I have to use Windows Task Manager to end it.
>
> Platform: Windows XP Pro (SP3)
>
> === LaTeX source file ===
> \documentclass{article}
> \begin{document}
> This is a test document by Murray.
> \end{document}
>
> === MiKTeX Problem Report generated automatically by Yap ---
>
> MiKTeX Problem Report
> Message: Invalid DVI file.
> Data:
> Source: C:\work3\miktex-2.9\Libraries\MiKTeX\Dvi\Dvi.cpp
> Line: 1108
> MiKTeX: 2.9
> OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
> Invokers: explorer/cmd
> SystemAdmin: yes
> PowerUser: no
> Root0: C:\Documents and Settings\Administrator\Application Data\MiKTeX\2.9
> Root1: C:\Documents and Settings\Administrator\Local
> Settings\Application Data\MiKTeX\2.9
> Root2: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.9
> Root3: D:\WP\localtexmf
> Root4: D:\WP\MiKTeX 2.9
> UserInstall: C:\Documents and Settings\Administrator\Application
> Data\MiKTeX\2.9
> UserConfig: C:\Documents and Settings\Administrator\Application
> Data\MiKTeX\2.9
> UserData: C:\Documents and Settings\Administrator\Local
> Settings\Application Data\MiKTeX\2.9
> CommonInstall: D:\WP\MiKTeX 2.9
> CommonConfig: C:\Documents and Settings\All Users\Application
> Data\MiKTeX\2.9
> CommonData: C:\Documents and Settings\All Users\Application Data\MiKTeX\2.9
>
> (What in the world is C:\work3\miktex-2.9\Libraries\ ?? Why is THAT there?)
>
> ==== DebugView log file ===
> [4572] 62 [yap.yap]: Yap arguments: testyap.dvi
> [4572] 1390 [yap.core]: Access is denied.
> [4572]
> [4572] Function: CreateProcess
> [4572] Result: 5
> [4572] Data: D:\WP\MiKTeX 2.9\miktex\bin\miktex-makepk.exe
> [4572] Source: Libraries\MiKTeX\Core\win\winProcess.cpp:359
> [3012] <<UI>>
> [3012] MMTask compacting.
> [3012]
> [3012] <<UI>>
> [3012] MMTask compacted, 1687552 bytes in largest available block.
>
> === Start of Windows XP PATH setting ===
> D:\WP\MiKTeX 2.9\miktex\bin;C:\WINDOWS\system32;C:\WINDOWS
>
> (although I have MiKTeX 2.8 also installed -- and with Yap working with
> same .tex source -- it's not on the PATH)
>
>

--
Murray Eisenberg                     [hidden email]
Mathematics & Statistics Dept.
Lederle Graduate Research Tower      phone 413 549-1020 (H)
University of Massachusetts                413 545-2859 (W)
710 North Pleasant Street            fax   413 545-1801
Amherst, MA 01003-9305

------------------------------------------------------------------------------
Lotusphere 2011
Register now for Lotusphere 2011 and learn how
to connect the dots, take your collaborative environment
to the next level, and enter the era of Social Business.
http://p.sf.net/sfu/lotusphere-d2d
_______________________________________________
MiKTeX-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/miktex-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Yap 2.9.3987 won't open dvi

Ulrike Fischer-2
In reply to this post by murrayE
Am Fri, 17 Dec 2010 23:20:45 -0500 schrieb Murray Eisenberg:

> Here's a minimal example showing the same Yap error I reported several
> days ago, but now running latex and yap from command line.
>
> Command-line steps:
>
>    latex testyap.tex
>    yap testyap.dvi
>
>
> In Yap, initially I get MiKTeX Problem Report window saying, "Not all
> fonts could be loaded...."  

Obviously YAP has problems to generate a font. It works fine for me.

Do the following:

1. Remove temporarly your localtexmf root.

2. Check that you have the newest miktex-runtime-bin package from
15. december. If not get it e.g. from the german dante or berlin
hosts. If you can't access a up-to-date repository through the
update manager go directly to the CTAN mirrors, download
miktex-runtime-bin-2.9 and the two miktex-zz....2.9 files. Put them
in an empty folder and use this as local repository.

3. Call on a command line the command "set". It will show you all
environments variable. Check them.

3. If the problem persists: Test if other mf-fonts are affected too.
E.g. the skak fonts (you will perhaps have to install them first):

\documentclass{article}
\usepackage[LSB,T1]{fontenc}
\begin{document}
\fontfamily{skak}\fontencoding{LSB}\fontsize{1cm}{1.5cm}\selectfont
This is a test document by Murray.
\end{document}
 
Test this example also with dvips.

4. If you have a multiuser install "for all users" log in in another
account and try there.


--
Ulrike Fischer


------------------------------------------------------------------------------
Lotusphere 2011
Register now for Lotusphere 2011 and learn how
to connect the dots, take your collaborative environment
to the next level, and enter the era of Social Business.
http://p.sf.net/sfu/lotusphere-d2d
_______________________________________________
MiKTeX-Users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/miktex-users
Loading...