Quantcast

Problem compiling Xelatex with fontspec package

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem compiling Xelatex with fontspec package

Alvin Toombs
I have MikTeX 2.9 loaded and used TeXworks (XeLateX compiler) for the following test program.

%Test fontspec2\documentclass[12pt]{article}\usepackage{fontspec} \setmainfont{Times New Roman}  \title{Sample font document} \author{Hubert Farnsworth} \date{this month, 2014} \begin{document}  \maketitle  This an \textit{example} of document compiled  with \textbf{xelatex} compiler. LuaLaTeX should  work fine also. \end{document}
The compile fails with an error message as follows:

|
 | fontspec.sty | 17 | Undefined control sequence.
l.17 \sys_if_engine_luatex:T |




The console log is as follows:
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class("C:\Users\Owner\AppData\Local\Programs\MiKTeX 2.9\tex\latex\base\size12.clo"))
("C:\Users\Owner\AppData\Local\Programs\MiKTeX 2.9\tex\latex\fontspec\fontspec.sty" (C:\Users\Owner\AppData\Roaming\MiKTeX\2.9\tex\latex\l3kernel\expl3.sty(C:\Users\Owner\AppData\Roaming\MiKTeX\2.9\tex\latex\l3kernel\expl3-code.tex("C:\Users\Owner\AppData\Local\Programs\MiKTeX 2.9\tex\latex\misc\etex.sty"))(C:\Users\Owner\AppData\Roaming\MiKTeX\2.9\tex\latex\l3kernel\l3unicode-data.def)(C:\Users\Owner\AppData\Roaming\MiKTeX\2.9\tex\latex\l3kernel\l3xdvipdfmx.def))
(C:\Users\Owner\AppData\Roaming\MiKTeX\2.9\tex\latex\l3packages\xparse\xparse.sty)! Undefined control sequence.l.17 \sys_if_engine_luatex:T ?

If I comment out the \usepackage{fontspec} and \setmainfont{Times New Roman} lines, the program compiles and runs perfectly.
I have tried reloading MikeTex 2.9 twice.  Once as 64 bit and again as 32 bit with the same result.
Anyone have suggestions as to a fix?
Thanks,Ed T






|
 |

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Q: How can I leave the mailing list?
A: See http://docs.miktex.org/faq/support.html#leavingml
Loading...